Pre-sales -- Install Scripts

4 posts / 0 new
Last post
#1 Sun, 05/21/2006 - 18:41
JeffRose

Pre-sales -- Install Scripts

how far behind the latest generation should we expect included script install/upgrades to be?

ie. in the Virtualmin demo, we can install outdated (read as security risks) versions of the following; I only checked the 4 listed below.

phpmyadmin Dec 2005 2.7.0-pl2 // current {2.8.1} XOOPS Jul 2005 2.0.13 // current {2.2.3} PHP-NUKE Apr 2003 6.5 // current {7.9}

( I appreciate that phpbb2 is able to be updated through Virtualmin to the latest version )

I am asking this not to be on the cutting edge of software, but as a security risk in a hosted environment. If I have multiple domains running outdated software, I have multiple security vulnerabilities that could be avoided if the installer/updater was configured to use more recent versions. Yes, this could be done manually, but I would rather simply click the update function in Virtualmin.

I would like to see Virtualmin maintenance updates include updates to the script installer as well. They should be included with each update if 3rd party updates are available.

Mon, 05/22/2006 - 17:39
Joe
Joe's picture

Hey Jeff,

We're trying to keep up, but possibly not doing the best job of it at the moment. I'm on some of the announce mailing lists for these scripts, but for others I've not done the digging needed to figure out how to subscribe and some don't offer an announce list or any way to be notified of new versions.

Anyway, I agree with you. And I'll try to figure out a way to better stay on top of versions of the installers.

--

Check out the forum guidelines!

Tue, 05/23/2006 - 18:59
JeffRose

Sounds fair enough :)

Wed, 05/24/2006 - 09:32
Joe
Joe's picture

And on that note, I'll mention that in response to this I spent all afternoon yesterday updating Install Scripts. I'm about halfway finished with the whole list (I hadn't realized how many of the things Jamie had added since I last spent time poking around in there...it's got a lot of scripts!).

I'm also spending a bit of time poking around to see if we can further automate some aspects of the install. At least one customer has been confused by the configuration step of phpBB (on first login after installation, the user is given a simple form to fill out to complete the installation, where one selects admin username and password, database name, etc.), and I believe we can probably make that step go away with a few additions to the install script.

Anyway, 3.16 or a revision soon after will have the latest version of all scripts. The additional configuration tricks might not see inclusion until sometime after that, but it'll also happen in the not too distant future.

--

Check out the forum guidelines!