Install script problem

4 posts / 0 new
Last post
#1 Wed, 06/28/2006 - 17:02
pnymat

Install script problem

Hi,

I am new to Virtualmin :)

I would like to use "Install Script" function of virtualmin to install phpmyadmin and Horde to my server, but i have always this error :

This script cannot be installed, as this virtual server does not meet its requirements : Horde requires the Apache mod_php4 module

I use Virtualmin 3.17 on a Fedore Core 5

Many thanks for help and sorry for niewbi questions ;)

Wed, 06/28/2006 - 17:30
pnymat

For information, i try the tip of the FAQ (http://www.virtualmin.com/faq/one-faq?faq_id=1511#16765) and restart httpd and virtualmin, but that seems to not work.

Wed, 06/28/2006 - 18:12
Joe
Joe's picture

Het Mathieu,

Yes, Fedora Core 5 has been problematic--the build of PHP4 I made for Fedora Core 4 doesn't build for FC5. I have, just yesterday, completed a build of PHP4 for Fedora Core 5, and the FAQ will work--though there is one additional step that I haven't yet added.

Instead of moving the /etc/httpd/conf.d/php.conf file to php.conf.disabled, edit it and comment out all of the directives (put a # in front of them), and then edit the php4.conf file and remove the # from in front of the LoadModule, AddType, and DirectoryIndex directives. Restart Apache, and things should work fine.

The reason for the change (which I'm adding to the FAQ right now) is that updates to PHP 5 would re-add the php.conf file and cause Apache to crash in odd ways (you can't have php5 and php4 loaded by Apache simultaneously, though there are no errors on startup when you try to do so--I find that very disturbing, but we'll just have to live with it).

--

Check out the forum guidelines!

Thu, 06/29/2006 - 02:24
pnymat

Ok many thanks, i will try this tommorow.