Do I need Perl module Authen::PAM?

4 posts / 0 new
Last post
#1 Thu, 08/24/2006 - 01:59
Blueforce

Do I need Perl module Authen::PAM?

Hi Joe, or anyone else that knows about this!

I get this message in webmin logfile after a reboot: [[24/Aug/2006:03:53:33 +0200]] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec/webmin /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi /usr/lib/perl5/5.8.6 .) at (eval 7) line 1. BEGIN failed--compilation aborted at (eval 7) line 1.

Should I have this modul installed? I find these moduls when looking them up whith yum, perl-Authen-DigestMD5.noarch 0.04-1.fc4 extras perl-Authen-Radius.noarch 0.12-2.fc4 extras perl-Authen-SASL.noarch 2.10-1.fc4 extras

If I need this module should I install all or just some of them?

Regards, Leif

Thu, 08/24/2006 - 21:30
Joe
Joe's picture

Hey Leif,

Yes, Authen-PAM is a good thing to have. I thought we provided it and installed it...I'm looking into it (the lack of this module might be the cause of another reported issue).

If it's not in our repo already, it will be very soon.

--

Check out the forum guidelines!

Fri, 08/25/2006 - 17:21 (Reply to #2)
Blueforce

Hi Joe,

Thanks for your reply.
Do I need to install all three packages mentioned earlier or just some of them, if so, whish ones do I need.

Regards,
Leif

Fri, 08/25/2006 - 17:40
Joe
Joe's picture

Hey Leif,

None of them. The only one you would need would be perl-Authen-PAM, which I'm bundling up now. Should be in the repositories by tomorrow.

--

Check out the forum guidelines!