Yum Priorities with Virtualmin

3 posts / 0 new
Last post
#1 Thu, 10/26/2017 - 15:47
Davio

Yum Priorities with Virtualmin

Hi Guys,

I have installed virtual min, on a system that initially had yum-plugin-priorities installed.

and have 2 questions after presenting all the information:)

EPEL repo activated

All the standard packages where installed also before installing virtualmin. eg yum-plugin-priorities dovecot dovecot-mysql postfix postgrey httpd php spamassassin wget htop mariadb mysql-server phpmyadmin

So I used installed with the install.sh, and most things went fine, except I noticed httpd was coming from another REPO causing the SUEXEC wrong home dir error.

At installation, VirtualMin had no prioritie so would have defaulted to 99

can I use priorities and what should they be?

Now I am using priority = 10 [virtualmin] priority = 10 [virtualmin-universal] priority = 15 [base] priority = 15 [updates] priority = 15 [extras] priority = 20 [epel]

Also should I re-install from fresh?

Id prefer not as it seems just to be a package problem

My current issue is; Resolving Dependencies --> Running transaction check ---> Package mod_fcgid.x86_64 0:2.3.7-1.el6 will be installed --> Processing Dependency: httpd-mmn = 20051115 for package: mod_fcgid-2.3.7-1.el6.x86_64 --> Finished Dependency Resolution Error: Package: mod_fcgid-2.3.7-1.el6.x86_64 (virtualmin) Requires: httpd-mmn = 20051115 Installed: 1:httpd-2.4.6-67.el7.centos.2.vm.x86_64 (@virtualmin) httpd-mmn = 20120211 httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 Available: 1:httpd-2.4.6-45.el7.centos.4vm.x86_64 (virtualmin) httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211

Thanks for your time,

Sat, 10/28/2017 - 02:41
Joe
Joe's picture

Yeah, you need our httpd packages (or you need to rebuild your own with the right changes). That's not optional, if you want all of the installer stuff to work...we expect user homes to be in /home.

I don't know anything about priorities, as I've never used them. But, I don't really recommend using third party repos in a haphazard way. If you absolutely need a non-standard package, use the yum includepkgs option in your repo config files to specify just the packages you want from specific repositories (you may have to expand the list to provide dependencies). There's just too many damned variables to make everything work together in a cohesive way if you're getting packages from a bunch of different sources.

You can force yum to install specific versions of packages, which is probably what you need to do to replace the wrong ones. You'll have to tell it to install an older version, as well. I'm surprised ours didn't already win the version war, because we bump the Epoch up 1 from the default Apache packages.

--

Check out the forum guidelines!

Sat, 10/28/2017 - 02:44
Joe
Joe's picture

Wait, what the heck...you've got EL6 and EL7 packages listed there. That looks like a mess! Is this a system that was upgraded from CentOS 6 to CentOS 7 somehow? That's not supported by the CentOS folks, as far as I know. You probably should start over (not because of Virtualmin's needs, but because I have no idea how an upgraded system would behave).

What CentOS version are you installing on?

--

Check out the forum guidelines!