Error in updaing PHP packages in webmin

4 posts / 0 new
Last post
#1 Sun, 11/11/2018 - 06:21
farshad
farshad's picture

Error in updaing PHP packages in webmin

Hi , trying to install updates from webmin updates . Now recieving errors . Also I cannot install php soap as well because there is a problem with my php installation.

Now updating php php-cli php-common php-fpm php-gd php-imap php-mbstring php-pdo php-pear php-process php-xml php-xmlrpc ..

Installing package(s) with command /bin/yum -y install php.x86_64 php-cli.x86_64 php-common.x86_64 php-fpm.x86_64 php-gd.x86_64 php-imap.x86_64 php-mbstring.x86_64 php-pdo.x86_64 php-pear.noarch php-process.x86_64 php-xml.x86_64 php-xmlrpc.x86_64 .. Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.danshin.pro * epel: mirror.de.leaseweb.net * extras: mirror.wiuwiu.de * remi: mirror.23media.de * updates: mirror.wiuwiu.de Resolving Dependencies --> Running transaction check ---> Package php.x86_64 0:5.4.16-45.el7 will be updated ---> Package php.x86_64 0:5.4.45-15.el6.remi will be an update --> Processing Dependency: httpd-mmn = 20051115 for package: php-5.4.45-15.el6.remi.x86_64 ---> Package php-cli.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-cli.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-common.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-common.x86_64 0:5.4.45-15.el6.remi will be an update --> Processing Dependency: libgmp.so.3()(64bit) for package: php-common-5.4.45-15.el6.remi.x86_64 ---> Package php-fpm.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-fpm.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-gd.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-gd.x86_64 0:5.4.45-15.el6.remi will be an update --> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: php-gd-5.4.45-15.el6.remi.x86_64 --> Processing Dependency: libpng12.so.0()(64bit) for package: php-gd-5.4.45-15.el6.remi.x86_64 ---> Package php-imap.x86_64 0:5.4.16-7.el7 will be updated ---> Package php-imap.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-mbstring.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-mbstring.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-pdo.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-pdo.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-pear.noarch 1:1.9.4-21.el7 will be updated ---> Package php-pear.noarch 1:1.10.6-1.el6.remi will be an update --> Processing Dependency: php-composer(fedora/autoloader) for package: 1:php-pear-1.10.6-1.el6.remi.noarch ---> Package php-process.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-process.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-xml.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-xml.x86_64 0:5.4.45-15.el6.remi will be an update ---> Package php-xmlrpc.x86_64 0:5.4.16-45.el7 will be updated ---> Package php-xmlrpc.x86_64 0:5.4.45-15.el6.remi will be an update --> Running transaction check ---> Package libpng12.x86_64 0:1.2.50-10.el7 will be installed ---> Package php.x86_64 0:5.4.45-15.el6.remi will be an update --> Processing Dependency: httpd-mmn = 20051115 for package: php-5.4.45-15.el6.remi.x86_64 ---> Package php-common.x86_64 0:5.4.45-15.el6.remi will be an update --> Processing Dependency: libgmp.so.3()(64bit) for package: php-common-5.4.45-15.el6.remi.x86_64 ---> Package php-fedora-autoloader.noarch 0:1.0.0-1.el7 will be installed --> Finished Dependency Resolution Error: Package: php-5.4.45-15.el6.remi.x86_64 (remi) Requires: httpd-mmn = 20051115 Installed: 1:httpd-2.4.6-80.el7.vm.3.x86_64 (@virtualmin) httpd-mmn = 20120211 httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 Available: httpd-2.4.6-80.el7.centos.x86_64 (base) httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211 Available: httpd-2.4.6-80.el7.centos.1.x86_64 (updates) httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211 Available: 1:httpd-2.4.6-80.el7.vm.2.x86_64 (virtualmin) httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211 Error: Package: php-common-5.4.45-15.el6.remi.x86_64 (remi) Requires: libgmp.so.3()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
Sun, 11/11/2018 - 06:44
farshad
farshad's picture

I think using this forum is waste of time as no one view this forum

Sun, 11/11/2018 - 08:29
farshad
farshad's picture
Sun, 11/11/2018 - 23:24
andreychek

Howdy,

Note that many third party repositories can indeed cause some dependency issues... it looks like your system has one or more of those enabled.

Where possible, we'd recommend using these instructions here for installing additional PHP versions, rather than using third party repositories:

https://www.virtualmin.com/documentation/web/multiplephp