.php downloading new install CentOS7

7 posts / 0 new
Last post
#1 Thu, 04/11/2019 - 17:21
j2sw

.php downloading new install CentOS7

Here is the skinny. Brand new VM of Centos7 Minimal. Followed this tutorial except I wasn't upgrading. https://www.virtualmin.com/node/48280

php -v PHP 7.2.17 (cli) (built: Apr 3 2019 10:02:16) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies with Zend OPcache v7.2.17, Copyright (c) 1999-2018, by Zend Technologies

Tried with 7.3 BTW with same result.

Order of what I have done. 1.Install Centos 7 minimal 2.Install PHP7 per above link 3.Install perl 4.Download and install virtualmin. 5.Add in domain. Have done a transfer from existing domain as well as created a new one.

Both try and download the PHP file instead of displaying it. PHP.conf is already commented, which was a suggestion of another thread.

Thoughts?

Thu, 04/11/2019 - 19:43
andreychek

Howdy,

What is the output of these commands -- this will show what repos are there, along with listing any sethandler lines which could be causing some trouble:

ls /etc/yum.repos.d/
find /etc/httpd -type f | xargs grep -i sethandler
Thu, 04/11/2019 - 22:34
j2sw
ls /etc/yum.repos.d/
CentOS-Base.repo         epel.repo          remi-php70.repo
CentOS-CR.repo           epel-testing.repo  remi-php71.repo
CentOS-Debuginfo.repo    install.sh         remi-php72.repo
CentOS-fasttrack.repo    remi-glpi91.repo   remi-php73.repo
CentOS-Media.repo        remi-glpi92.repo   remi.repo
CentOS-SCLo-scl.repo     remi-glpi93.repo   remi-safe.repo
CentOS-SCLo-scl-rh.repo  remi-glpi94.repo   virtualmin.repo
CentOS-Sources.repo      remi-modular.repo
CentOS-Vault.repo        remi-php54.repo
find /etc/httpd -type f | xargs grep -i sethandler
/etc/httpd/conf.d/php.conf:#        SetHandler application/x-httpd-php
/etc/httpd/conf.d/php.conf:    #    SetHandler application/x-httpd-php-source

j2sw.com

Thu, 04/11/2019 - 23:00
andreychek

Hmm, it looks like there's a number of non-standard repos enabled... I suspect that's why you're seeing the issue, though the typical cause for that, a "SetHandler" line, doesn't appear to be the issue in this case.

You may want to try and see if using a different PHP Execution Mode helps -- you can change that in Server Configuration -> Website Options.

-Eric

Thu, 04/11/2019 - 23:06
j2sw

The only repros i added where at the link in my first message. My whole goal of this is to create a server for WordPress running php7

Does anyone have a good tutorial getting cirtualnin and php7 properly working?

Do I need to have 5 installed? Right now it’s not.

j2sw.com

Fri, 04/12/2019 - 00:01
andreychek

Howdy,

There's actually more third party repos enabled on your server than I've ever seen before :-)

I count at least 12.

Those remi repos don't come with Virtualmin, and we recommend against those.

You could check by running "rpm -qa | grep php" -- however, if any of the PHP versions installed came from one of those third party repos, that's likely the issue.

Are you perhaps using a VPS? If you have a VPS image there built by someone else, that could explain how those got there.

-Eric

Fri, 04/12/2019 - 04:07
Jfro

FYI. in remi.repo for example you should have the right versions and such enabled=1 or even when not enabled=0

Also other repos you should enable and update and other conflicting has to be disable also for updates only those wich are in use if all in use then be sure you stay with problems!

Not saying this helps or even that i know how to solve. ;

With the Remi repos you have to do more in settings / configs manually for having those working as expected.

Before only one version of php fpm working is / was possible in virtualmin. also important.

The newer should support more fpm i don't know if this works while in bugs / issues you can readr about that. Still then the Remi combo is not tested i suppose . https://www.virtualmin.com/node/55788

So we only use one PHP FPM the 5.6 remi repo while this one is mostly and quicker up to date for older (to old) php version very important. ( having this working good was a lot of websearch and pa.. in the as.. for that time i installed) Updates we don't have trouble with PHP sofar running over 1 year now

The php 5.4 in virtualmin hmmmmmmmmmmmmmmmmmm

My text is for info only hoping you are taking care of conflicts. ?

This should give any help howto >. https://www.unixmen.com/enable-disable-repositories-centos/

Keyword: yum repolist there you seee which php in yum repo are in use. Here from remi only php 5.6 fpm and safe