500 Internal server error after updating PHP above 7.0 on debian

3 posts / 0 new
Last post
#1 Tue, 04/16/2019 - 13:50
Huiwu

500 Internal server error after updating PHP above 7.0 on debian

So I need php version 7.1 or above on my server. I installed php 7.1, 7.2, as well as 7.3. Problem is that I would get the 500 error if I switch to anything other than 7.0. How do I access php error log on virtualmin? Any help would be greatly appreciated.

Tue, 04/16/2019 - 13:58
andreychek

Howdy,

Anytime the website produces a 500 error, you should see additional information in the Apache error logs for that domain located in $HOME/logs/error_log.

-Eric

Tue, 04/16/2019 - 16:23
Huiwu

Thanks for the quick reply turns out I was missing php7.#-cgi package. Install with command "sudo apt-get install php7.2-cgi" hopefully this can help someone else. Best.