[BACKUP] Virtualmin FTP backups not working anymore after update

4 posts / 0 new
Last post
#1 Tue, 05/28/2019 - 06:03
lumina

[BACKUP] Virtualmin FTP backups not working anymore after update

Hello,

I'm using Virtualmin for quite a time. I have a small server running Webmin+Virtualmin. Backups were running with no problem (to ftp domain).

I upgrade webmin from 1.872 to 1.9. Virtualmin is 6.06.gpl.

The backups are not working anymore and I can't change anything in the scheduled backup. When I want to save, I have the error: "Failed to save scheduled backup : FTP server hostname cannot be resolved"

On the backup logs, here is the error for the last backup since update: "Failed to connect to FTP server : Failed to lookup IP address for ftp.mydomain.com"

I check firewalls: - ip not banned (from the webmin server and the backup server)

Other think linked probably: - Backup in webmin for filesystem: same problem when I want to update a scheduled backup, I have the following error: "Failed to save backup : Missing or invalid host to backup to"

The field are correctly fullfilled in the scheduled backup page (it was working before...): ftp server, file name, etc...

I check on forum. I don't find any posts related to my problem.

Any ideas?

Mon, 06/10/2019 - 10:43
lumina

UP please. I haven't made any progress to solve this problem.

Tue, 06/11/2019 - 08:21
scotwnw

"hostname can not be resolved" is a problem. Figure out why it can not resolve. DNS correct? If you do ping ftp.domain.com from the server itself, does it show an ip and start pinging? If you do ping ftp.domain.com from home, does it resolve to an ip and ping correctly? If you pit the ip itself into the backup form, does it work then?

Wed, 06/12/2019 - 11:08 (Reply to #3)
lumina

Thank you for your time to answer me. The ping is working correctly for the domain. There are different domains on the same ip so I don't know if I can put the ip to replace the domain.

The only customised stuff in my configuration is: ftp.domain.com:XXXX, XXXX=special port for ftp, but it was working before.

I found this on another virtualmin discussion and it was working great since 1 year.