3 posts / 0 new
Last post
#1 Fri, 05/31/2019 - 13:16
BBuchanan1013

Don't Get it

Fresh install
Centos 7
Enabled Remi repo
Upgraded php from 7.0 to 7.1

First domain, host-true.com is blank on purpose and shows the forbidden to view since I don't have anything there.
Second domain, almostgonephoto.com, nothing there but shows a directory from somewhere
Hostname, sv1.host-true.com shows blank like host-true.com
Preview works (I think, I could be wrong, but it looks like it does)

Any idea's?

Fri, 05/31/2019 - 13:23
andreychek

Howdy,

We recommend against using third party repositories, as unusual things can happen.

If you're looking to use newer PHP versions, our recommendation for that is this procedure here:

https://www.virtualmin.com/documentation/web/multiplephp#toc-installing-...

However, the symptoms you're describing may also be this issue here (which isn't PHP related):

https://www.virtualmin.com/documentation/web/troubleshooting#toc-the-wro...

Fri, 05/31/2019 - 13:36 (Reply to #2)
BBuchanan1013

I take responsibility for the php.

 
enp5s0f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether b4:99:ba:aa:54:55 brd ff:ff:ff:ff:ff:ff
    inet 69.197.145.146/29 brd 69.197.145.151 scope global noprefixroute enp5s0f1
       valid_lft forever preferred_lft forever
    inet6 2604:4300:a:1::2/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 2604:4300:a:1:b699:baff:feaa:5455/64 scope global noprefixroute dynamic
       valid_lft 2591999sec preferred_lft 604799sec
    inet6 fe80::b699:baff:feaa:5455/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
# grep -i '<virtualhost' /etc/httpd/conf/httpd.conf
 
<VirtualHost 69.197.145.146:80 [2604:4300:a:1::2]:80>
<VirtualHost 69.197.145.146:443 [2604:4300:a:1::2]:443>
<VirtualHost 69.197.145.146:80 [2604:4300:a:1::2]:80>
<VirtualHost 69.197.145.146:443 [2604:4300:a:1::2]:443>

I have determined that even tho apache/httpd conf has /home/almostgonephoto/public_html it's actually reading from /var/www/html while the other domain, host-true, is reading from the correct directories