Scheduled backup to Amazon S3 failes (for only one virtual server)

5 posts / 0 new
Last post
#1 Tue, 06/25/2019 - 02:44
crus

Scheduled backup to Amazon S3 failes (for only one virtual server)

Hi,

I have four virtual virtual servers which I backup daily to an Amazon S3 bucket for a few years now (one file per server). About a week ago the backup started to fail for one of the virtual servers. The error message I get:

Error message: Uploading archive to Amazon's S3 service .. upload failed! Empty response to HTTP request. Headers were : (I can't find anything else in any of the other log files.)

The file is about 200MB and the backup process gets cancelled after approx. 40 minutes.

The other virtual servers of the backup are backed up just fine. I made a manual backup out of the scheduled backup (download in browser) and that went just fine.

Can anyone help me out?

Thanks and regards

crus

Wed, 07/03/2019 - 18:40
FalconOnline

I've been having this issue as well - on a server that's not changed (other than updates) and has been running and backing up fine for months now. Suddenly about half the virtual servers are failing. I've tried setting up a new VPS with a new virtualmin instance and importing all the servers into that but still the same result.

As with crus above, I can still download all the backups in my browser no problem.

Running Virtualmin 6.06-2 on Ubuntu 18.04.2. Backups are to an Ireland bucket.

Thanks!

Wed, 07/24/2019 - 05:07
crus

Can nobody help us with this issue?

Wed, 07/24/2019 - 12:39 (Reply to #3)
FalconOnline

I guess the support here isn't what it once was :)

I 'solved' my issue by migrating to a US based region (Oregon, to be precise), backups have been working fine since then. Not quite the fix I wanted, but it is working and that's the most important thing.

Different regions seem to have different setups (I've never been able to use London, for example), I guess something has changed at Amazon's end to make virtualmin fail like this.

Mon, 07/29/2019 - 04:10
crus

Thanks for letting me know how you were able to solve the issue. I tried it (moving everything from Ireland to Oregon) but I receive the same error for one specific domain. I will try to use a ftp server instead, perhaps it has nothing to do with s3 which I doubt.