bandwidth / rate limiting

5 posts / 0 new
Last post
#1 Tue, 06/25/2019 - 08:03
zoltan

bandwidth / rate limiting

Hello,

I just migrated to virtualmin from cpanel / whm. Everything went well for 3-4 days but now, my sites are not accessible any more. I tried to debug Apache / PHP but could not find any issue. The pages are starting to download but after a while connection is reset.

Later I discovered that I can upload files very fast to the server (4-5 MB / sec) but downloading via web browser and even an scp client is working with only 2-4 KB / sec!!! Is there a bandwidth limit enabled, how should I check what is limiting my access to the sites and cause the slow page downloading?

I stopped fail2ban, iptables show no blocking rules, I have no idea what else should I check.

The main issue seems to be the slow speed of download between my location and the server. But I have other servers on the same DC and download works very well between my location and the other server. This is why I assume there is some kind of built in bandwidth limiting on webmin / virtualmin.

Any suggestion / help is appreciated.

Tue, 06/25/2019 - 08:14
zoltan

And one more thing. Since we are hosting about 20-30 GB of mails on this server, it is possible that after we moved, all our employees from the office downloaded the IMAP folders. Obviously all downloads came from the same office IP.

Tue, 06/25/2019 - 15:47
zoltan

I would really appreciate some help here. So, basically my entire Virtualmin server is very very fast from certain locations and it slows down to 3-4 kb / sec per download on various other locations. I tested it via tens of VPNs from all around the world and I have issues on at least 70-80% of locations I used, the rest of 20-30% were extremely fast. Check this picture for example: http://www.tradeholding.com/luxury.jpg It is a 4 MB file and if you have luck, it will download in max 1-2 seconds! If not, you will see the picture is slowly downloading before Apache times out.

When I try to download the same image to my PC via an SCP client it doesn't stop but it is downloading with 3-4 kb / sec.

Uploading seems to be fine from every location I tested, the same 4 MB file is uploaded in max 1-2 secs.

What can be on Virtualmin / Webmin that is limiting my download speed?

Wed, 06/26/2019 - 08:45
scotwnw

Luxury.jpg downloads instantly here, South East US. And within a few seconds over tor network via Europe. Nothing in webmin/virtualmin will limit bandwidth per ip.
Start a download and run a trace route to see if/where packet loss or high ping is occurring. Has to be something going on along the route.

Wed, 06/26/2019 - 15:12
zoltan

Thanks for the comments. Here is an MTR between my location and the server:

7.|-- 213.198.77.197 0.0% 10 46.9 47.3 46.3 53.2 2.0 8.|-- ae-2.r04.frnkge08.de.bb.gin.ntt.net 0.0% 10 48.4 48.7 47.7 54.1 1.8 9.|-- be2914.agr41.fra03.atlas.cogentco.com 0.0% 10 47.6 48.0 46.9 53.2 1.8 10.|-- be3187.ccr42.fra03.atlas.cogentco.com 0.0% 10 46.5 47.4 46.4 53.2 2.0 11.|-- be2800.ccr42.par01.atlas.cogentco.com 0.0% 10 65.3 65.5 65.1 66.0 0.0 12.|-- be3628.ccr42.jfk02.atlas.cogentco.com 0.0% 10 132.6 133.2 132.6 133.9 0.0 13.|-- be2807.ccr42.dca01.atlas.cogentco.com 0.0% 10 134.8 134.4 133.9 134.9 0.0 14.|-- be2113.ccr42.atl01.atlas.cogentco.com 0.0% 10 149.7 149.6 149.1 149.9 0.0 15.|-- be2848.ccr41.atl04.atlas.cogentco.com 0.0% 10 150.3 151.4 150.0 160.3 3.1 16.|-- 38.122.46.74 0.0% 10 157.9 164.3 157.0 222.4 20.4 17.|-- dct-cr01--v51.mydedservercompany.com 10.0% 10 165.4 168.2 165.4 176.1 3.8 18.|-- dct-ds42-ve33.mydedservercompany.com 90.0% 10 159.0 159.0 159.0 159.0 0.0 19.|-- dct-ds17-vl64.mydedservercompany.com 10.0% 10 158.1 157.9 157.3 158.2 0.0

You can see on hop 18 a 90% packet loss. I ran the same test several times, and there is always a 90% packet loss at that hop. I sent this info to the dedicated company and got this response: "Ping loss that doesn't continue onward is not actual loss, rather it is a hop not responding to those packets in favor of processing actual traffic packets instead. As the 90% loss does not continue forward, it does not appear there is actual loss."

I am not an expert here, but can this be the main issue?