problems with dual php installation

1 post / 0 new
#1 Tue, 07/23/2019 - 12:14
warren0728

problems with dual php installation

so i managed to install php 7.2.10 in addition to 5.4.16 but am having issues when i do "recheck configuration"

i'm not sure if this is php related or not but when i do the "recheck configuration" i get the following error on the first check ... Apache configuration errors were found :

AH00526: Syntax error on line 954 of /etc/httpd/conf/httpd.conf: FcgidIOTimeout must be greater than 0

.. your system is not ready for use by Virtualmin.

so i go to line 954 and change the value of "IPCCommTimeout" to 31 (which is the value all other instances of "IPCCommTimeout")

i then go back to "recheck configuration" and it runs fine and says my system is ready for virtualmin ... BUT ...

there is a line in the output that says "PHP versions have changed to 5, 5.4, 7.2 since last check. Regenerating any missing php.ini files." when the output ends and says "your system is ready for virtualmin" if i run "recheck configuration" immediately it throws the same error as above and the "IPCCommTimeout" for the one domain is reset to "0" again.

i am confused why my change of "IPCCommTimeout" from "0" to "31" for the specific domain (same one everytime) doesn't stick and gets reset back to "0"

my goal is to get all the domains running on 7.2 ...

any ideas?

thanks in advance!