Forbidden You don't have permission to access / on this server

2 posts / 0 new
Last post
#1 Mon, 10/07/2019 - 10:00
Dibs

Forbidden You don't have permission to access / on this server

Hi,

I have had a server running for at least a yr with virtualmin running about 2 virtual hosts - no real issues. I added a 3rd on about 4 days ago and that worked fine. Then today, trying to access the home page of any of them resulted in,

"Forbidden You don't have permission to access / on this server"

I did do a search and found something similar on https://www.virtualmin.com/node/64797#comment-811344 and changed the top line for each host (.conf file) at /etc/apache2/sites/available/

from

VirtualHost *:80 [removed the <> brackets as they wouldn't post.]

to

VirtualHost 123.123.123.123:80 [removed the <> brackets as they wouldn't post.]

where 123.123.123.123 represents the server IP address. Restarted apache and the websites seem to be behaving normally.

I'm stumped as to why all of a sudden things went from working to not working. I would appreciate any thoughts or help as to where to look. The apache error logs don't appear to show anything that jumps out.

Many Thanks

Mon, 10/07/2019 - 13:11
Dibs

I placed a simple index.html file in the public_html folder of the "master" domain and that's the one that showed when I tried to access the home page of any of the VirtualHosts, when all the VirtualHosts had the 1st line as ....*:80.

I also looked at https://www.virtualmin.com/documentation/web/troubleshooting#toc-the-wro... and verified none of the VirtualHosts have a * for ports 80 or 443.

Just stumped as to why everything went from working to longer working. Anyone ideas?

The server is a Linode VPS, running Ubuntu 16.04 and Virtualmin 6.07 GPL, with Apache 2.4.18

Thanks