Trouble with GPL Install Script and Ubuntu 8.04

16 posts / 0 new
Last post
#1 Fri, 05/09/2008 - 22:38
dimpared

Trouble with GPL Install Script and Ubuntu 8.04

Hello,

I'm attempting to use the newest GPL install script on a fresh install of Ubuntu 8.04 (amd64) and am receiving a few errors. I was wondering if someone may be of some assistance. The last few lines of the install log read as follows:

The following packages have unmet dependencies: virtualmin-base: Depends: procmail-wrapper but it is not installable Depends: webmin-virtual-server but it is not installable Depends: webmin-virtualmin-dav but it is not going to be installed Depends: webmin-virtualmin-mailman but it is not going to be installed Depends: webmin-virtualmin-svn but it is not going to be installed FATAL - 2008-05-10 07:25:57 - Fatal Error Occurred: Installation failed: 0 FATAL - 2008-05-10 07:25:58 - Cannot continue installation. FATAL - 2008-05-10 07:25:58 - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - 2008-05-10 07:25:58 - re-attempted after any problems have been resolved. FATAL - 2008-05-10 07:25:58 - Removing temporary directory and files. FATAL - 2008-05-10 07:25:58 - If you are unsure of what went wrong, you may wish to review the log FATAL - 2008-05-10 07:25:58 - in /root/virtualmin-install.log

Any help would be greatly appreciated.

cheers<br><br>Post edited by: dimpared, at: 2008/05/09 22:41

Fri, 05/09/2008 - 22:58
Joe
Joe's picture
Sat, 05/10/2008 - 09:28
r.fluttaz

Hi !
I've trouble to install the gpl version too, but on a 32bit systeme ...

[code:1]Checking for HTTP client...found /usr/bin/wget -nv
Checking for perl...found /usr/bin/perl
18:25:03 URL:http://software.virtualmin.com/lib/spinner [579/579] -&gt; &quot;spinner&quot; [1]
Loading log4sh logging library...
18:25:03 URL:http://software.virtualmin.com/lib/log4sh [21395/21395] -&gt; &quot;log4sh&quot; [1]
INFO - Started installation log in /root/virtualmin-install.log
INFO - Checking for fully qualified hostname...
INFO - Hostname OK: fully qualified as web2.botux.net
INFO - Installing serial number and license key into /etc/virtualmin-license
INFO - Loading OS selection library...
18:25:04 URL:http://software.virtualmin.com/lib/oschooser.pl [4448/4448] -&gt; &quot;oschooser.pl&quot; [1]
INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - Loading OS list...
18:25:04 URL:http://software.virtualmin.com/lib/os_list.txt [3482/3482] -&gt; &quot;os_list.txt&quot; [1]
INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.
INFO - Operating system name: Ubuntu Linux
INFO - Operating system version: 8.04
INFO - Configuring package manager for Ubuntu Linux 8.04...
INFO - Enabling universe repositories, if not already available...
INFO - Disabling cdrom repositories...
Hit ftp://mir1.ovh.net hardy Release.gpg
Hit http://security.ubuntu.com hardy-security Release.gpg
Hit ftp://mir1.ovh.net hardy-updates Release.gpg
Hit ftp://mir1.ovh.net hardy Release
Hit http://security.ubuntu.com hardy-security Release
Hit ftp://mir1.ovh.net hardy-updates Release
Hit ftp://mir1.ovh.net hardy/main Packages
Hit http://security.ubuntu.com hardy-security/main Packages
Hit ftp://mir1.ovh.net hardy/restricted Packages
Hit ftp://mir1.ovh.net hardy/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Packages
Hit http://security.ubuntu.com hardy-security/main Sources
Hit ftp://mir1.ovh.net hardy/restricted Sources
Hit http://security.ubuntu.com hardy-security/restricted Sources
Hit http://security.ubuntu.com hardy-security/universe Packages
Hit http://security.ubuntu.com hardy-security/universe Sources
Hit http://security.ubuntu.com hardy-security/multiverse Packages
Hit http://security.ubuntu.com hardy-security/multiverse Sources
Hit ftp://mir1.ovh.net hardy/universe Packages
Hit ftp://mir1.ovh.net hardy/universe Sources
Hit ftp://mir1.ovh.net hardy/multiverse Packages
Hit ftp://mir1.ovh.net hardy/multiverse Sources
Hit ftp://mir1.ovh.net hardy-updates/main Packages
Hit ftp://mir1.ovh.net hardy-updates/restricted Packages
Hit ftp://mir1.ovh.net hardy-updates/main Sources
Hit ftp://mir1.ovh.net hardy-updates/restricted Sources
Hit ftp://mir1.ovh.net hardy-updates/universe Packages
Hit ftp://mir1.ovh.net hardy-updates/universe Sources
Hit ftp://mir1.ovh.net hardy-updates/multiverse Packages
Hit ftp://mir1.ovh.net hardy-updates/multiverse Sources
Reading package lists... Done
INFO - Cleaning up apt headers and packages, so we can start fresh...
INFO -
18:25:06 URL:http://software.virtualmin.com/lib/apt.conf.noninteractive [243/243] -&gt; &quot;apt.conf.noninteractive&quot; [1]
INFO - Download of http://software.virtualmin.com/lib/apt.conf.noninteractive Succeeded.
INFO - Installing Webmin and Virtualmin package signing keys...
18:25:06 URL:http://software.virtualmin.com/lib/RPM-GPG-KEY-virtualmin [1690/1690] -&gt; &quot;RPM-GPG-KEY-virtualmin&quot; [1]
INFO - Download of http://software.virtualmin.com/lib/RPM-GPG-KEY-virtualmin Succeeded.
18:25:06 URL:http://software.virtualmin.com/lib/RPM-GPG-KEY-webmin [1320/1320] -&gt; &quot;RPM-GPG-KEY-webmin&quot; [1]
INFO - Download of http://software.virtualmin.com/lib/RPM-GPG-KEY-webmin Succeeded.
INFO - OK
INFO - OK
INFO - Hit
INFO - Removing Debian standard Webmin package, if they exist (because they're broken)...
INFO - Removing Debian apache packages...
INFO - Installing dependencies using command: /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip quota
...in progress, please wait...
Extracting templates from packages: 100%
Extracting templates from packages: 100%
...........................
INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip quota: Succeeded.
INFO - Succeeded.
INFO - Installing Virtualmin and all related packages now using the command:
INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base
...in progress, please wait...
.E: Broken packages

/usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualmin-base: Depends: webmin-virtual-server but it is not installable
Depends: webmin-virtualmin-dav but it is not going to be installed
Depends: webmin-virtualmin-mailman but it is not going to be installed
Depends: webmin-virtualmin-svn but it is not going to be installed

FATAL - Fatal Error Occurred: Installation failed: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log
[/code:1]

Is there any way to finish the installation ?
Thanks

Sat, 05/10/2008 - 12:09
solcott

I have the same problem as r.fluttaz. I get the exact same output he does from the script.

Fresh install of Ubuntu 8.04 (x86) with the first and only thing I have run so far since the install is the Virtualmin install script.

Sat, 05/10/2008 - 12:18
r.fluttaz

Dirty fix :

[code:1]wget http://download.webmin.com/download/virtualmin/webmin-virtual-server_3.5...
sudo dpkg -i webmin-virtual-server_3.56.gpl_all.deb[/code:1]

And relunch the install ...
(this install will be corupted ?)

Tue, 05/13/2008 - 22:46
baroch

Hi.

I've tried on a fresh Ubuntu 8.04 i386 install, but similar problems occur.

here is the log:
<div class='quote'>

INFO - 2008-05-14 09:45:27 - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install postfix postfix-pcre webmin usermin ruby libapache2-mod-ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip quota: Succeeded.
INFO - 2008-05-14 09:45:27 - Succeeded.
INFO - 2008-05-14 09:45:27 - Installing Virtualmin and all related packages now using the command:
INFO - 2008-05-14 09:45:27 - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.

The following packages have unmet dependencies:
virtualmin-base: Depends: webmin-virtual-server but it is not installable
Depends: webmin-virtualmin-dav but it is not going to be installed
Depends: webmin-virtualmin-mailman but it is not going to be installed
Depends: webmin-virtualmin-svn but it is not going to be installed

</div>

Tue, 05/13/2008 - 23:22 (Reply to #6)
baroch

Sorry, I didn't notice post #12396, which suggestion worked for me :-)

Fri, 05/16/2008 - 03:25
solcott

I guess I'm wondering if Joe knows of a 'real' fix for this, like does this script care <i>which</i> Ubuntu 8.04 you are running. Like does it care if it's Ubuntu JeOS, or Ubuntu Server, or Ubuntu Desktop, or Ubuntu CLI (from that 5MB netboot cd) or EduBuntu or what. I've tried all of them so far, except EduBuntu, with the same result of the script dying when it tries to install webmin-virtual-server

Fri, 05/16/2008 - 09:22 (Reply to #8)
Joe
Joe's picture

It should be fixed with yesterday's sync of the repositories. But, I might be wrong. I'll test it today to be sure.

But, yes, the fix suggested above is fine--it is exactly what I would have recommended, had not been so busy trying to get the new version tested and rolled out.

--

Check out the forum guidelines!

Sun, 05/18/2008 - 03:56
r.fluttaz

Now i got another error :

[code:1]INFO - Installing Virtualmin and all related packages now using the command:
INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base
...in progress, please wait...
Extracting templates from packages: 100%
Extracting templates from packages: 100%
................................................................................................E: Sub-process /usr/bin/dpkg returned an error code (1)

/usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
Allowing traffic on TCP port: pop3
Allowing traffic on TCP port: pop3s
Allowing traffic on TCP port: imap
Allowing traffic on TCP port: imaps
Allowing traffic on TCP port: http
Allowing traffic on TCP port: https
Allowing traffic on TCP port: 10000
Allowing traffic on TCP port: 20000
Allowing traffic on UDP port: domain
dpkg: error processing virtualmin-base (--configure):
subprocess post-installation script returned error exit status 255
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
virtualmin-base

FATAL - Fatal Error Occurred: Installation failed: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log
[/code:1]

any ideas ?

Sun, 05/18/2008 - 13:04 (Reply to #10)
Joe
Joe's picture

That's really weird. That's a complete and successful install, as far as I can tell--I'm not sure why virtualmin-base would have exited with an error, as all of its tasks completed. I'll have to do some test installs here to see if I can reproduce it.

I believe your system is fine, though--you should be able to login on port 10000 and everything should be working.

--

Check out the forum guidelines!

Sun, 05/18/2008 - 04:45
r.fluttaz

My logfile (attached)

Sun, 05/18/2008 - 04:46
r.fluttaz

(sorry i cant edit my post ...) [file name=virtualmin_install-6671e0a1f9385363361f441d628d7a2e.txt size=91267]http://www.virtualmin.com/components/com_fireboard/uploaded/files/virtua...

Thu, 05/29/2008 - 16:22
chris@borngraph...

how is the official fix coming. I would really like to get this working. The same issue is occurring on the paid version as well as the GPLed. Well this is obvious since it is a package issue... :-)

Thu, 05/29/2008 - 16:40 (Reply to #14)
Joe
Joe's picture

I've fixed the missing procmail-wrapper package on amd64, as far as I know, if that's the source of this problem. I dunno about other problems, as I haven't seen them.

--

Check out the forum guidelines!

Mon, 06/29/2009 - 22:54
Francewhoa
Francewhoa's picture

I wrote a how-to handbook at http://ubuntuforums.org/showthread.php?t=1197883 It covers installing Virtualmin, Webmin & Usermin on Ubuntu Server 8.04 LTS.

- - -
Senior Product Manager, and Co-Founder at Ubertus.org Inc.
Love back your Virtualmin & Webmin community