Apache and version of php

7 posts / 0 new
Last post
#1 Mon, 11/04/2019 - 07:48
Raphael40

Apache and version of php

Hello,

I'm using a Dedie server that runs under Centos7, with Webmin 1.932 and virtualmin (glp) 6.08 Kernel Linux 4.19.62-mod-std-ipv6-64-rescue on x86_64. i installed on virtualmin php 7.2.10 and php 5.4.45 gold i would need to run Apache with php 5.5.9 but currently it works with php 5.4.45. (my new apps that I try to run ask me 5.5.9 minimum)

For example, when I try to install Matomo on a virtual server configure in php 7.2.10, I get this type of messsage:

Error in Matomo: To run Matomo you need PHP PHP 5.5.9 Unfortunately it seems your webserver is using PHP version 5.4.45.

Could someone explain to me how to operate apache with php5.5.9 see 7.2.10? please thank you

Have a good day

Raphael

Mon, 11/04/2019 - 10:32
unborn
unborn's picture

@Raphael40 - hello, how are you?

as you point right: Error in Matomo: To run Matomo you need PHP PHP 5.5.9 Unfortunately it seems your webserver is using PHP version 5.4.45.

and then you siad Could someone explain to me how to operate apache with php5.5.9 see 7.2.10? please thank you

i think you should be asking centos community or matomo community before you even ask here.. ? it should make sense at all..

good luck

Configuring/troubleshooting Debian servers is always great fun

Mon, 11/04/2019 - 14:17
Dibs

@Raphael40 - If I understand you correctly: your server has php 7.2.10 and php 5.4.45 but apps (Matomoto) require php 5.5.9 or higher. And when you try to install one of these apps - it complains that it only sees php 5.4.45 (which is too low a version number).

Have a look at https://vpsfix.com/7091/multiple-php-versions-virtualmin-nginx/ - ignore the nginx reference but look at the section labelled "Configure Virtualmin to use a Specific PHP Version". This is to change it at a Virtual Server level. It might be also worth looking at System Settings - Server Templates - Default Settings: Pull down the drop down for PHP Options and see what the box labelled "Default PHP version" is set to and see what it has in it. I would expect 3 entries (Highest, 7.2.10 & 5.4.45). It might be set to 5.4.45. In which case set it to 7.2.10 or highest. But this will only apply to NEW virtualServers created.

For existing ones - refer to the link I posted and the section I refer to.

HIH

Dibs

Mon, 11/04/2019 - 17:57
briand

I think this is the same as we posted here https://www.virtualmin.com/node/67567

I did assume that if you had PHP 7.x then it would be OK, but perhaps you can't use PHP7 but need to upgrade PHP5 as well, it would be good to know if it' an install problem or whether need to upgrade PHP 5.x

Mon, 11/04/2019 - 18:18
Jfro

Don't know but PHP 5.x is EOL

Some as REMI repo do backporting but there only PHP 5.6.4x

If using old EOL versions please take care of extra security measures and have a not to long time plan when to update PHP and APPS

Mon, 11/04/2019 - 22:21
Dibs

If you installed everything, created VirtualServer and then upgraded or added a later version of PHP - the VirtualServer may still effectively be "stuck" at the original install version. Best check as per my earlier comment. Even new VirtualServerswhen created may also be "stuck" at the earlier version - unless the Default Template says otherwise.

HIH

Dibs

Tue, 11/05/2019 - 02:11
briand

In my case this is a new server (couple months ago) and I have not updated php. I will check the templates to see if default is PHP 5.x

I had created a new domain and tried to install magento

Thanks Brian